Unexpected response code: 400 & WebSocketException - Handshake failed


I have encountered some problems with Red5Pro server and HTML5 SDK. I ran server (developer licence) locally and it worked. Then I ran your app https://github.com/red5pro/streaming-android (with some little changes, like library name etc but nothing big) and it worked, I published and I saw stream on subscribe.jsp page on localhost. I opened stream in new page and I saw:

[Red5ProSubscriber] Connect.Failure.

In Chrome Developer Tools I saw:

WebSocket connection to 'ws://[my IP]:8081/live?id=subscriber-2bb5' failed: Error during WebSocket handshake: Unexpected response code: 400

In running server's console I saw:

org.red5.net.websocket.codec.WebSocketDecoder - Handshake failed org.red5.net.websocket.WebSocketException - Handshake failed, path not enabled.

Here is log from console:

Should I enable WebSocket or WebRTC somewhere? I didn't find about it  anything here: https://www.red5pro.com/docs/server/webrtc/. I think everything is OK with my PC - in my workplace I have encountered the same problems. Weird part is that I can connect with API, to list active streams for example, and subscribing worked with Flash version. Or maybe there are some restrictions on free developer licence? I will be grateful if I find help here - thank you in advance for your time.

P.S. I also created a StackOverflow Question about my problem: http://stackoverflow.com/questions/41202595/red5-pro-unexpected-response-code-400-websocketexception-handshake-failed


Please sign in to leave a comment.