Google Play x86 Console Error

QUESTION:

When I try to upload my release to Google Play, the console shows the following error thrown by the x86 folders in jniLibs of the Red5 Pro Android SDK: 

"This release is not compliant with the Google Play 64-bit requirement.

The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: 11.

Include 64-bit and 32-bit native code in your app. Use the Android App Bundle publishing format to automatically ensure that each device architecture receives only the native code it needs. This avoids increasing the overall size of your app."

How do I fix this?

 

ANSWER:

We recommend removing the x86 architecture altogether to solve this problem.

Review the following Google Play Requirements taken from the Android Developers site:  

"If you are using any external SDKs or libraries, ensure you are using 64-bit versions by following the steps above. Reach out to the SDK or library owner if a 64-bit version is not available and take this into account when planning your support for 64-bit devices."

x86 (32 bit) does not have a 64 bit counterpart. Since virtually all x86 Android devices are legacy at this time, we find removing the x86 architecture to be the best fix.

The following StackOverflow thread goes over how to disable x86 architecture for a number of different IDEs:

https://stackoverflow.com/questions/57561855/apks-or-app-bundles-are-available-to-64-bit-devices-but-they-only-have-32-bit-na

 Created 11/6/2020 MD;

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.