Software Dependencies - CentOS 7

QUESTION:

Why does the Red5 Pro Server fail to run on CentOS 7? 

ANSWER:

CentOS 7 requires certain software dependencies. See the the following SSL information for proper configuration.

Software Dependencies - CentOS 7

Note: Red5 Pro with WebRTC does not run on CentOS 6 due to an older and less secure version of glibc that has been updated with CentOS 7. If you want to run Red5 Pro on CentOS, you must use build 7 (note that we have not tested with CentOS 8).

Open SSL Configuration for CentOS

IMPORTANT: Because of different libcrypto library versions supported between CentOS and Ubuntu, with release 5.2.2 it is necessary to modify {red5pro}/conf/webrtc-plugin.properties, and change openssl.enabled=true to openssl.enabled=false.

Depending on your permissions, you may need to pre-pend the following commands with sudo:

yum -y update
yum -y install java unzip jsvc ntp libva libvdpau

https://www.red5pro.com/docs/server/ubuntuinstall.html#software-dependencies---centos-7

https://www.red5pro.com/docs/server/ubuntuinstall.html#open-ssl-configuration-for-centos

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.