Broadcast Fails on Azure-Based Server: IP issues

QUESTION:

On an Azure Ubuntu 13 machine, the Red5Pro server displays the welcome page at: mywebsite.cloudapp.net:5080 But on the broadcast page, after naming the stream and clicking Start Broadcast, publishing fails - the elapsed time remains zero and after a few moments: NetConnection.Connect.Failed appears in the status box.

Is there a problem with my IP address?

 

ANSWER:

There may be.  Azure VMs have a public virtual IP (VIP) assigned to the cloud service as well as a DHCP-assigned IP (DIP), used for communicating within Windows Azure.  The VIP is the DNS-resolved address for mywebsite.cloudapp.net, but the Red5Pro server may configure itself with the DIP, which is not a public IP in a default Azure setup.  (On the VM, ifconfig returns the DIP).

Resolve this by either (A) creating an instance-level public IP (PIP) on the Azure VM or (B) manually configuring Red5Pro with the correct IP address at the Welcome Screen.

A.  Use the Azure management console to enable an instance-level IP.  (For more on Azure configuration please see this FAQ)

B.  Manually configure the Red5Pro server:

      1.  Get the VIP from a terminal window with: ping -c 1 mywebsite.cloudapp.net

      2.  Refresh the Welcome page at: mywebsite.cloudapp.net:5080

      3.  In the upper right corner, click on Not the correct IP address? and paste the IP from step 1 into the dialog box.

      4.  The VIP is displayed.  Proceed to the broadcast page and create your stream as usual.

      5.  Repeat these steps after Red5Pro server restarts.

Note: Additionally, make sure the required ports are open on the Windows Firewall as in the “Endpoints” policy.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.